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PART-A 

Answer any FIVE of the following:                                                5x4=20Marks 

1. Write about Secondary memory devices. 

2. Write about Keyboard. 

3. How to create and save documents in word? 

4. Describe the features of fonts in MS Word? 

5. What are text boxes in Excel? How do you use them? 

6. How to create templates in PowerPoint? 

7. What is the use of MS Access in handling database? 

8. How to view and delete relationships in Access? 

            PART-B 

Answer ALL Questions                                                                       5x8M=40Marks 

1. A) Explain block diagram of Digital Computer. 

 

                                                                         (OR) 

            B). Explain about types of Operating System. 

 

2. A) Explain various features of a word processor. 

 

(OR) 

B). What are headers and footers? How to create basic headers and footers? 

 

3. A) What is formula? How to use formulas in Excel? 

     (OR) 

B) How to manage work books in Excel? 

 

4. A) Explain the Features of M.S. Power Point? 

 

      (OR) 

B). How to create a PowerPoint presentation? Explain. 

5. A)  What are the advantages and features of MS Access? 

                                                           (OR)                    

B) Explain about the data the types and properties available in MS Access. 
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Study Material

Unit I
Essay Questions:

1. Explain block diagram of Digital Computer.
2. Explain about types of Operating System.
3. Explain any three Input devices.
4. Explain any three Output devices.
5. Explain Characteristics features of computer.
6. Explain applications of computer.

Short Questions:

1. Define computer and hardware.
2. Write about Keyboard.
3. Write about VDU
4. Write about Secondary memory devices.

Unit II

Essay Questions:

1. Explain various features of a word processor.
2. Explain different parts of word window.
3. Explain about character formatting in word.
4. Explain paragraph formatting in MS Word.
5. What are headers and footers? How to create basic headers and footers?
6. How to apply bullets and numbers in a document?

Short Questions:

1. How to create and save documents in word?
2. Explain what are the various ways of undo and redo typing text.
3. Explain the importance of tables in MS Word.
4. Describe the features of fonts in MS Word?
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Unit III

Essay Questions:

1. Describe the significant features of MS Excel Software.
2. How to manage work books in Excel?
3. How to enter and edit text in an excel worksheet?
4. What is formula? How to use formulas in Excel?
5. Explain how to format text in Excel?
6. Explain the features of MS. Excel?

Short Questions:

1. What are text boxes in Excel? How do you use them?
2. What are text notes in Excel? How is it useful?
3. Explain how can we perform spell checking in Excel?
4. Explain about cutting, copying and pasting in Excel.

Unit IV

Essay Questions:

1. Explain the various parts of PowerPoint window.
2. How to create a PowerPoint presentation? Explain.
3. Explain the following in PowerPoint.

a. Making changes in slides.
b. Applying a theme to a slide.
c. Adding a background.
d. Running a PowerPoint slide show

4. How can you customize a presentation?
5. Explain the Features of M.S.PowerPoint?
6. What are the various parts of slides in PowerPoint?

Short Questions:

1. How to create templates in PowerPoint?
2. Explain the procedure for adding slides to a PowerPoint presentation.
3. How to insert a sound in a PowerPoint presentation?
4. What is custom animation in PowerPoint? Explain.
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Unit V

Essay Questions:

1. What is MS Access? Explain different components of MS Access.
2. What are the advantages and features of MS Access?
3. Explain the procedure to create databases without the wizard.
4. List and explain various properties of text fields.
5. Explain about the data the types and properties available in MS Access.
6. What are various parts in an Access expression?

Short Question:

1. What is the use of MS Access in handling database?
2. What are the various ways to rename a field both in data sheet and design view?
3. List the data entry and navigational shortcuts in MS Access.
4. How to view and delete relationships in Access?
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UNIT-I

Essay Questions & Answers
1. Explain block diagram of Digital Computer.

Input Unit

This unit contains devices with the help of which we enter data into the computer. This unit

creates a link between the user and the computer. The input devices translate the information

into a form understandable by the computer.

CPU (Central Processing Unit)

CPU is considered as the brain of the computer. CPU performs all types of data processing

operations. It stores data, intermediate results, and instructions (program). It controls the

operation of all parts of the computer.

CPU itself has the following three components −

ALU (Arithmetic Logic Unit)

Memory Unit

Control Unit

Output Unit

The output unit consists of devices with the help of which we get the information from

the computer. This unit is a link between the computer and the users. Output devices translate

the computer's output into a form understandable by the users.
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2. Explain about types of Operating System.

The objectives of the operating system are −

 To make the computer system convenient to use in an efficient manner.

 To hide the details of the hardware resources from the users.

 To provide users a convenient interface to use the computer system.

 To act as an intermediary between the hardwa

Characteristics of Operating System

Here is a list of some of the most prominent characteristic features of Operating Systems −

 Memory Management − Keeps track of the primary memory, i.e. what part of it is in

use by whom, what part is not in use, etc. and allocates the memory when a process or

program requests it.

 Processor Management − Allocates the processor (CPU) to a process and deallocates

the processor when it is no longer required.

 Device Management − Keeps track of all the devices. This is also called I/O controller

that decides which process gets the device, when, and for how much time.

 File Management − Allocates and de-allocates the resources and decides who gets the

resources.

 Security − Prevents unauthorized access to programs and data by means of passwords

and other similar techniques.

 Job Accounting − Keeps track of time and resources used by various jobs and/or users.

 Control over System Performance − Records delays between the request for a

service and from the system.

 Interaction with the Operators − Interaction may take place via the console of the

computer in the form of instructions. The Operating System acknowledges the same,

does the corresponding action, and informs the operation by a display screen.

 Error-detecting Aids − Production of dumps, traces, error messages, and other

debugging and error-detecting methods.

 Coordination between Other Software and Users − Coordination and assignment of

compilers, interpreters, assemblers, and other software to the various users of the

computer systems.
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3. Explain any three Input devices.

Following are some of the important input devices which are used in a computer −

 Keyboard

 Mouse

 Joy Stick

 Light pen

 Track Ball

 Scanner

 Graphic Tablet

 Microphone

 Magnetic Ink Card Reader(MICR)

 Optical Character Reader(OCR)

 Bar Code Reader

 Optical Mark Reader(OMR)

Keyboard

Keyboard is the most common and very popular input device which helps to input data to the

computer. The layout of the keyboard is like that of traditional typewriter, although there are

some additional keys provided for performing additional functions.

Mouse
Mouse is the most popular pointing device. It is a very famous cursor-control device having a

small palm size box with a round ball at its base, which senses the movement of the mouse

and sends corresponding signals to the CPU when the mouse buttons are pressed.

Joystick
Joystick is also a pointing device, which is used to move the cursor position on a monitor
screen. It is a stick having a spherical ball at its both lower and upper ends.
Light Pen

Light pen is a pointing device similar to a pen. It is used to select a displayed menu item or

draw pictures on the monitor screen. It consists of a photocell and an optical system placed in

a small tube.

Track Ball
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 Track ball is an input device that is mostly used in notebook or laptop computer,
instead of a mouse. This is a ball which is half inserted and by moving fingers on the
ball, the pointer can be moved.

Scanner

 Scanner is an input device, which works more like a photocopy machine. It is used

when some information is available on paper and it is to be transferred to the hard

disk of the computer for further manipulation.

Microphone

 Microphone is an input device to input sound that is then stored in a digital form.



 The microphone is used for various applications such as adding sound to a multimedia

presentation or for mixing music.

Optical Mark Reader (OMR)

OMR is a special type of optical scanner used to recognize the type of mark made by pen or

pencil. It is used where one out of a few alternatives is to be selected and marked.

It is specially used for checking the answer sheets of examinations having multiple choice

questions.

4. Explain any three Output devices.

Following are some of the important output devices used in a computer.

 Monitors

 Graphic Plotter

 Printer

Monitors
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Monitors, commonly called as Visual Display Unit (VDU), are the main output device of a

computer. It forms images from tiny dots, called pixels that are arranged in a rectangular

form. The sharpness of the image depends upon the number of pixels.

There are two kinds of viewing screen used for monitors.

 Cathode-Ray Tube (CRT)

 Flat-Panel Display

Cathode-Ray Tube (CRT) Monitor

The CRT display is made up of small picture elements called pixels. The smaller the pixels,

the better the image clarity or resolution. It takes more than one illuminated pixel to form a

whole character, such as the letter ‘e’ in the word help.

There are some disadvantages of CRT −

 Large in Size

 High power consumption

Flat-Panel Display Monitor

The flat-panel display refers to a class of video devices that have reduced volume, weight and

power requirement in comparison to the CRT

Printers

Printer is an output device, which is used to print information on paper.

There are two types of printers −

 Impact Printers

 Non-Impact Printers

Impact Printers

Impact printers print the characters by striking them on the ribbon, which is then pressed on

the paper.

Characteristics of Impact Printers are the following −

 Very low consumable costs

 Very noisy

 Useful for bulk printing due to low cost

 There is physical contact with the paper to produce an image
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These printers are of two types −

 Character printers

 Line printers

5. Explain Characteristics features of computer.

The characteristics of the computer system are as follows –

Speed

A computer works with much higher speed and accuracy compared to humans while

performing mathematical calculations. Computers can process millions (1,000,000) of

instructions per second. The time taken by computers for their operations is microseconds

and nanoseconds.

Accuracy

Computers perform calculations with 100% accuracy. Errors may occur due to data

inconsistency or inaccuracy.

Diligence

A computer can perform millions of tasks or calculations with the same consistency and

accuracy. It doesn’t feel any fatigue or lack of concentration. Its memory also makes it

superior to that of human beings.

Versatility
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Versatility refers to the capability of a computer to perform different kinds of works with

same accuracy and efficiency.

Reliability

A computer is reliable as it gives consistent result for similar set of data i.e., if we give same

set of input any number of times, we will get the same result.

Automation

Computer performs all the tasks automatically i.e. it performs tasks without manual

intervention.

Memory

A computer has built-in memory called primary memory where it stores data.

Secondary storage are removable devices such as CDs, pen drives, etc., which are also used

to store data.

6. Explain applications of computer.

Business

A computer has high speed of calculation, diligence, accuracy, reliability, or

versatility which has made it an integrated part in all business organizations.

Computer is used in business organizations for −

 Payroll calculations

 Budgeting

 Sales analysis

 Financial forecasting

 Managing employee database

.
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Banking

Today, banking is almost totally dependent on computers.

Banks provide the following facilities −

 Online accounting facility, which includes checking current balance, making deposits

and overdrafts, checking interest charges, shares, and trustee records.

Insurance

Insurance companies are keeping all records up-to-date with the help of computers.

Insurance companies, finance houses, and stock broking firms are widely using computers for

their concerns.

Insurance companies are maintaining a database of all clients with information showing −

 Procedure to continue with policies

 Starting date of the policies

 Next due installment of a policy

 Maturity date

 Interests due

 Survival benefits

 Bonus
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Education

The computer helps in providing a lot of facilities in the education system.

 The computer provides a tool in the education system known as CBE (Computer Based

Education).

 CBE involves control, delivery, and evaluation of learning.

Marketing

In marketing, uses of the computer are following −

 Advertising − With computers, advertising professionals create art and graphics, write

and revise copy, and print and disseminate ads with the goal of selling more products.

Healthcare

 Diagnostic System − Computers are used to collect data and identify the cause of

illness.

 Lab-diagnostic System − All tests can be done and the reports are prepared by

computer.

Military

 Missile Control

 Military Communication

 Military Operation and Planning
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 Smart Weapons

Communication

Communication is a way to convey a message, an idea, a picture, or speech that is received

and understood clearly and correctly by the person for whom it is meant. Some main areas in

this category are −

 E-mail

 Chatting

 Usenet

 FTP

 Telnet

 Video-conferencing

Government

Computers play an important role in government services. Some major fields in this category

are −

 Budgets

 Sales tax department

 Income tax department

UNIT-I
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Short Questions & Answer
1. Define Computer and Hardware.

Computer

Computer is an advanced electronic device that takes raw data as an input from the

user and processes it under the control of a set of instructions (called program), produces a

result (output), and saves it for future use. This tutorial explains the foundational concepts of

computer hardware, software, operating systems, peripherals, etc. along with how to get the

most value and impact from computer technology.

Hardware

The term hardware refers to mechanical device that makes up computer. Computer

hardware consists of interconnected electronic devices that we can use to control computer’s

operation, input and output. Examples of hardware are CPU, keyboard, mouse, hard disk, etc.

Hardware Components

Computer hardware is a collection of several components working together. Some

parts are essential and others are added advantages. Computer hardware is made up of CPU

and peripherals as shown in image below.

2. Write about Keyboard.
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Keyboard

Keyboard is the most common and very popular input device which helps to input

data to the computer. The layout of the keyboard is like that of traditional typewriter,

although there are some additional keys provided for performing additional functions.

S.No Keys & Description

1

Typing Keys

These keys include the letter keys (A-Z) and digit keys (09) which

generally give the same layout as that of typewriters.

2

Numeric Keypad

It is used to enter the numeric data or cursor movement. Generally, it

consists of a set of 17 keys that are laid out in the same configuration used

by most adding machines and calculators.

3

Function Keys

The twelve function keys are present on the keyboard which are arranged

in a row at the top of the keyboard. Each function key has a unique

meaning and is used for some specific purpose.

4

Control keys

These keys provide cursor and screen control. It includes four directional

arrow keys. Control keys also include Home, End, Insert, Delete, Page Up,

Page Down, Control(Ctrl), Alternate(Alt), Escape(Esc).

5

Special Purpose Keys

Keyboard also contains some special purpose keys such as Enter, Shift,

Caps Lock, Num Lock, Space bar, Tab, and Print Screen.
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3. Write about VDU

The term VDU is a more seasoned British term, which stands for visual display unit

and uses to describe any device to show text and pictures. For case, examples of VDU are

a projector and a flat-panel display. Although the term VDU usually depicts the CRT

(Cathode Ray Tube) screen, a presently age-old standard that has been replaced by LED

screens (flat-panel display). VDU functions to display pictures that are generated by any

electronic devices like computer system.

The term VDU is often referred to use synonymously with "monitor," but it can also

be used to describe the display as a digital projector. Generally, it is a device that may be

integrated with the other components or may be peripheral devices. For instance, an all-

in-one design is used by Apple iMac, in which computers and screens are integrated into

a single unit.

4. Write about Secondary memory devices.

Characteristics of Secondary Memory

These are some characteristics of secondary memory, which distinguish it from primary

memory −

 It is non-volatile, i.e. it retains data when power is switched off

 It is large capacities to the tune of terabytes

 It is cheaper as compared to primary memory

Depending on whether secondary memory device is part of CPU or not, there are two

types of secondary memory – fixed and removable.



K.MACHAR RAO, MCA Page 17

Unit II
Essay Questions & Answers

1. Explain various features of a word processor.

Word processing software provides tools for creating all kinds of text based

documents. Word processors are not limited to working with text: they enable you to add

images to your documents A word processor can enhance documents in other ways. You can

ernbed sounds, video chips and animation into them.
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The word processor's interface:

The word processor's main editing window displays a document and several tools. A

word processor provides several set of tools as following.

1. A menu bar, which displays titles of menus.

2. Tool bars, which display buttons that represent frequently used commands.

3. Rulers, which show the positions of text, tabs, margins etc.

4. Scroll bars, which let you scroll through a document.

5. A status bar, which displays information related to your position in the document, the

page count, and the status of keyboard keys.

Entering and Editing Text:

You create a document by typing on the keyboard. Wordprocessor lets you to change

text without retyping the entire age.

The word processor’s real beauty is its ability to work with bocks of text. A block is

contiguous group of characters, words, lines, Sentences, or paragraphs that you mark for

editing.

Formatting text: The process of formatting a document includes controlling the appearance

of text, the layout of text on page, and the use of pictures and other graphic elements.

Character formatting: This includes settings that controlattributes of individual text

characters such as fonts, font size atype style.

Paragraph formatting: This includes settings applied only one or more entire paragraphs,

such as line spacing, paragraph spacing, indents, alignment, tabs, borders, or shading

Document formatting: This includes size of the page, aorientation, and headers or footers.

2. Explain different parts of word window.
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File Tab

The File tab replaces the Office button from Word 2007. You can click it to check
the backstage view. This is where you come when you need to open or save files, create new
documents, print a document, and do other file-related operations.

Quick Access Toolbar

This you will find just above the File tab. This is a convenient resting place for the most
frequently used commands in Word. You can customize this toolbar based on your comfort.

Ribbon
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Ribbon contains commands organized in three components −

 Tabs − these appear across the top of the Ribbon and contain groups of related
commands. Homes, Insert, Page Layout are examples of ribbon tabs.

 Groups − they organize related commands; each group name appears below the group
on the Ribbon. For example, group of commands related to fonts or group of
commands related to alignment, etc.

 Commands − Commands appear within each group as mentioned above.

Title bar

This lies in the middle and at the top of the window. Title bar shows the program and
document titles.

Rulers

Word has two rulers - a horizontal ruler and a vertical ruler. The horizontal ruler appears just
beneath the Ribbon and is used to set margins and tab stops. The vertical ruler appears on the
left edge of the Word window and is used to gauge the vertical position of elements on the
page.

Zoom Control

Zoom control lets you zoom in for a closer look at your text. The zoom control consists of a
slider that you can slide left or right to zoom in or out; you can click the + buttons to increase
or decrease the zoom factor.

Document Area

This is the area where you type. The flashing vertical bar is called the insertion point and it
represents the location where text will appear when you type.

Status Bar

This displays the document information as well as the insertion point location. From left to
right, this bar contains the total number of pages and words in the document, language, etc.

3. Explain about character formatting in word.

Making text bold

We use bold text to give more emphasis on the sentence. It is very simple to change a

selected portion of text into bold font by following two simple steps −
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Step 1 − Select the portion of text that the font of which needs to be made bold. You can use

any of the text selection methods to select the portion of text.

Step 2 − Click the Font Bold [ B ] button in the Home tab Font group, or simply use Ctrl +

B keys to make the selected portion of text bold.

Making Text Italic

An italic text appears with a small inclination and we use the italicized text to differentiate it

from other text. It is very simple to change the selected text into italic font by following two

simple steps −

Step 1 − Select the portion of text the font of which needs to be italicized. You can use any of

the text selection methods to select the portion of text.

Step 2 − Click the Font Italic [ I ] button in the Home tab Font group, or simply use

the Ctrl + I keys to convert the portion of text in italic font.

Underline the Text

An underlined portion of text appears with an underline and we use the underlined portion of

text to make it more distinguished from other text. It is very simple to change the selected

text into underlined font by following two simple steps −

Step 1 − Select the portion of text which needs to be underlined. You can use any of the text

selection method to select the portion of text.

Step 2 − Click Font Underline [ U ] button in the Home tab Font group, or simply use

the Ctrl + U keys to put an underline under the text.

Strikethrough the Text

Step 1 − Select the portion of text that you want to change to a bold font. You can use any of

the text selection method to select the portion of text.

Step 2 − Click Font Strikethrough [ abc ] button in the Home tab Font group to put a line

in the middle of the text which is called strikethrough the text.

Change Text to Sentence Case

Step 1 − Select the portion of text that that needs to be put in sentence case. You can use any

of the text selection methods to select the portion of text.
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Step 2 − Click the Change Case button and then select the Sentence Case option to

capitalize the first character of every selected sentence.

Change Text to Lowercase

Step 1 − Select the portion of text that needs to be put in lowercase. You can use any of the

text selection methods to select the portion of text.

Step 2 − Click the Change Case button and then select Lowercase option to display all the

selected words in lowercase.

Change Text to Uppercase

Step 1 − Select the portion of text that you want to change to a bold font. You can use any of

the text selection method to select the portion of text.

Step 2 − Click the Change Case button and then select UPPERCASE option to display all

selected words in all caps. All characters of every selected word will be capitalized.

Capitalize Text

Step 1 − Select the portion of text that needs to be capitalized. You can use any of the text

selection method to select the portion of text.

Step 2 − Click the Change Case button and then select the Capitalize Each Word option to

put a leading cap on each selected word.

Change Font Colors

The text that we type comes in black by default; you can always change the color of the font

to a color of your choice.

Highlight Text with Colors

You can highlight a selected portion of text using any color and it will look like it was

marked with a highlighter pen. Usually we highlight a text using yellow color.

4.Explain paragraph formatting in MS Word.

Left-Aligned Text
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Step 1 − Click anywhere on the paragraph you want to align and click the Center button

available on the Home tab or simply press the Ctrl + E keys.

Right-Aligned Text

Step 1 − Click anywhere on the paragraph you want to align and click the Align Text

Right button available on the Home tab or simply press the Ctrl + R keys.

Justified Text

Step 1 − Click anywhere on the paragraph you want to align and click the Justify button

available on the Home tab or simply press the Ctrl + J keys.

Left Indentation

Left indentation means to move the left edge of the paragraph inward towards the center of
the paragraph. Let us use the following steps to create left indentation.

Step 1 − Click anywhere on the paragraph you want to indent left and click the Increase
Indent button available on the Home tab or simply press the Ctrl + M keys. You can click
multiple times to create deeper indentation.

Step 2 − You can remove left indentation by clicking the Decrease Indent button available

on Home tab or simply press Ctrl + Shift+ M keys. You can click multiple times to remove

deeper indentation.

Right Indentation

Right indentation means to move the right edge of the paragraph inward towards the center of
the paragraph. Let us use the following steps to create right indentation.

Step 1 − Click anywhere on the paragraph you want to indent and then click on the Increase
Right Indent spinner available on the Page Layout tab. You can click on the spinner multiple
times to create deeper indentation. You can use the Left Indent spinners as well to set left
indentation from the same place.

First Line Indentation

Step 1 − Click anywhere on the paragraph you want to indent right and click the Paragraph
Dialog Box launcher available on the Home tab.

Step 2 − Click the Before Text spinner to set left indentation and select the First Line
Option to move the left side of the first line of a paragraph inward toward the center. You
can control the movement by setting the Indentation Unit. A preview box will give only the
idea and not the indentation status.
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5. What are headers and footers? How to create basic headers
and footers?

Headers and footers are parts of a document that contain special information such as page
numbers and the total number of pages, the document title, company logo, any photo, etc.
The header appears at the top of every page, and the footer appears at the bottom of every
page.

Add Header and Footer

The following steps will help you understand how to add header and footer in a Word
document.

Step 1 − Click the Insert tab, and click either the Header button or the Footer
button that which needs to be added first. Assume you are going to add Header; when
you click the Header button it will display a list of built-in Headers from where you can
choose any of the headers by simply clicking on it.

Step 2 − Once you select any of the headers, it will be applied to the document in editable
mode and the text in your document will appear dimmed, Header and Footer
buttons appear on the Ribbon and a Close Header and Footer button will also appear at
the top-right corner.

Step 3 − Finally, you can type your information whatever you want to have in your
document header and once you are done, click Close Header and Footer to come out of
the header insertion mode. You will see the final result as follows.

Edit Header and Footer

The following steps will help you understand how to edit the existing header or footer of
your document.

Step 1 − Click the Insert tab, and click either the Header button or Footer button or
whatever you want to edit. Assume you are going to edit the Header, so when you click
the Header button it will display a list of options including the Edit Header option.

Step 2 − Click on the Edit Header option and Word will display the editable header as
shown in the following picture
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Step 3 − Now you can edit your document header and once you are done, click Close
Header and Footer to come out of the edit header mode.

6. How to apply bullets and numbers in a document?

Microsoft Word automatically assigns page numbers on the pages of your document.

Typically, page numbers are printed either in header or footer but you have the option that

can display the page number in the left or right margins at the top or the bottom of a page.

Add Page Numbers

Following are the simple steps to add page numbers in a Word document.

Step 1 − Click the Insert tab, and click the Page Number button available in the header

and footer section. This will display a list of options to display the page number at the top,

bottom, current position etc

Step 2 − When you move your mouse pointer over the available options, it displays

further styles of page numbers to be displayed. For example, when I take the mouse

pointer at the Bottom of Page option it displays the following list of styles.
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Step 3 − finally, select any one of the page number styles. I selected the Accent Bar

1 style by clicking over it. You will be directed to the Page Footer modification mode.

Click the Close Header and Footer button to come out of the Footer Edit mode.

You can format your page numbers using the Format Page Numbers option available

under the listed options.

Create a List from Existing Text

This is very simple to convert a list of lines into a bulleted or numbered list. Following

are the simple steps to create either bulleted list or numbered list.

Step 1 − Select a list of text to which you want to assign bullets or numbers. You can use

any of the text selection method to select the portion of text.

Step 2 − Click the Bullet Button triangle to display a list of bullets you want to assign to

the list. You can select any of the bullet style available by simply clicking over it.

Step 3 − If you are willing to create a list with numbers, then click the Numbering

Button triangle instead of the bullet button to display a list of numbers you want to assign

to the list. You can select any of the numbering style available by simply clicking over it.

UNIT-II

Short Questions & Answer
1. How to create and save documents in word?

Create:-

Word always starts by opening an untitled 'normal' document so that you can begin
from scratch. This 'normal' document is based upon all the default values provided by
word i.e. standard page size, standard margins, font type and size etc. You can change
these setting and create your own customised documents based upon new settings. You
can save your new settings in a specific kind of file, called a template file, which will help
you to quickly create documents based upon these customised settings. You can create
your own letter-heads, fax-sheets, invoices, and memos etc. as templates. Since these
templates are like ready-made, pre-printed forms, all you have to do is fill in the blanks,
very similar to filling in forms manually. Paper

Saving New Document
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Once you are done with typing in your new Word document, it is time to save your

document to avoid losing work you have done on a Word document. Following are the

steps to save an edited Word document −

Step 1 − Click the File tab and select the Save As option.

Step 2 − Select a folder where you will like to save the document, Enter the file name

which you want to give to your document and Select the Save As option, by default it is

the .docx format.

Step 3 − finally, click on the Save button and your document will be saved with the

entered name in the selected folder.

2. Explain what the various ways of undo and redo typing text.

Undo a Single Change

Click the Undo button.

Press Ctrl + Z.

Your last action is undone. For example, if you had deleted an item and then decided you
wanted to keep it after all, undo would make it reappear.

Undo a Multiple Changes

Click the Undo list arrow.

Select a change to undo everything since that point

The command you select and all subsequent actions are undone.

Redo

Redo is the opposite of undo: it redoes an action you have undone. For example, if you

decide that you do, after all, want to delete an item that you have just brought back with

undo, you can redo the action.

The Redo button is only available right after you’ve undone something. When Redo isn’t

available, the button is replaced by the Repeat button.

Click the Redo button.

Press Ctrl + Y.

The last action you undid is redone.
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Click the Redo button multiple times to redo multiple actions

3. Explain the importance of tables in MS Word.

Tables help you organize complex columnar information. Use them to create such
diverse documents as forms, financial reports, parts catalogs, and resumes. You can insert
tables anywhere you need them in Word documents.

Word tables consist of horizontal rows and vertical columns. You do the typing in
areas called cells. Cells contain text, numbers, or graphics. The text in cells is edited and
embellished as usual with word's formatting tool bar and ruler.

A number of table-specific features let you control the size,shape and appearance of
cells. Border and shading features areAvailable. It is also easy to insert and delete rows
and columns.

Tables can be created from existing text without needless retyping, or you can use the
table feature to organize information and then convert your table to text. You can even
import and export table data.

4. Describe the features of fonts in MS Word?
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If you want to see the available font styles for a particular font, follow these steps:

1. Select the text you want to affect.

2. Choose the Font option from the Format menu. Word displays the Font dialog box.

3. From the Font list, select the font you want to use. 4. Examine the Font Style list to
see which styles are available for the font.

5. When à are done, click on OK.

Unit III
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Essay Questions & Answers
1. Describe the significant features of MS Excel Software.

MS-Excel is a powerful spreadsheet application which allows different types of

calculations very easily. This holds data. Formulate and graphic objects (pictures). MS-Excel

has three components:

(1) The spreadsheet component: It displays and Analyses text and numbers in rows and

columns.

(2) The Database component: It manipulates lists of information

(3) The Chart component: It produces charts which help to present data in a graphical

manner. When we start Excel; two windows appear on the screen one nested within the other.

(1) Application window,

(2) Document window.

1. Application window: The application window of Excel has the following components

(a) Title Bar: It appears at the top of the MS-Excel window.

(b) Menu Bar: Below the title bar is the Menu Bar, which lists the names of nine menus

(File, Edit, View, Insert, Format, Tools, "Data, Window and Help)

(c) Formatting Toolbar:-It contains tool buttons which are used to carry out standard

program operations for e.g. spell check, cut, paste, Auto sum, sort etc(d) Formatting

Toolbar: It contains tool buttons to d frequently used formatting commands.

For eg. Font, Font-size, S Italics etc..

Status Bar: It appears at the bottom of the window. The left part displays various

messages/prompts. The Right part displays keyboard status indicators.

2. Document window: It displays the currently active worksheet. It consists of the

Following

(a) Title Bar: It is the bar at the top of the document window

It displays the name of the workbook.

(b) Control Menu: It consists maximise and minimise button.
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(c) Sheet tabs: These tabs at the bottom of the document window. These are used to

select different worksheets.

(d) Column Heading: The letters at the top of the worksheet column. Ex: A, B, C, D, E...

(e) Row Heading: The numbers at the left of each worksheetEx: 1, 2, 3...

2. How to manage work books in Excel?
1. Click Microsoft Office Button and then click New.
2. Under Templates, make sure that Blank and recent is selected, and then under Blank

and recent in the right pane, double-click Blank Workbook. Keyboard shortcut To
quickly create a new, blank workbook, you can also press CTRL+N.

(i) Opening an existing workbook:

Click the Office button and choose Open:

The Open dialog appears. This dialog box is divided into two sections: a my box Places
panel on the left and a folder and file list box on the right.

If you want to open a workbook in another folder, click the Look In drop-down list button
and select the folder that contains the file. Click the file you want to open and then click
the Open button, or double-click the file's icon. You Use the Views button drop-down
menu on the Open dialog box to change the way folder and file icons appear in the dialog
box.

(ii) Saving a workbook:

1. You can use the Save As command to save a worksheet for the first time.
2. Office 2007- From the Office button choose Save As. Office 2003 From the File

menu choose Save As.
3. In the File name box, type a name for the worksheet.
4. Click Save.

(iii) Closing a workbook:

1. Office 2007 - From the Office button choose Close. Office 2003 From the File menu
chooses Close.

2. If necessary, save the worksheet.
3. If you want to quit Excel, Office 2007 - From the Office button choose Quit. Office

2003 - From the File menu choose Quit.

(iv)Deleting a workbook:
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In the 'Look In' box, click the drive or folder that contains the workbook to be deleted.
In the folder list, double click the folder that contains the workbook to be deleted. Right
click the workbook to be deleted, and then click 'delete' on the short cit menu that appears.

3. How to enter and edit text in an excel worksheet?

Enter Text:

To enter the text used to label things in your worksheets, simply activate the cell when

you want the text to appear (point to it and click), and then begin typing. As you start

typing, the text will appear in the active cell andin the formula bar. Pressing ENTER or

clicking the check mousebutton in the formula bar concludes the text entry and places

the textin active cell.

Editing Text:

If you spot an error which entering text, simply backspace to correct it. If you see an

error after finishing the entry, activate the ell and edit the text. Use your windows text-

editing skills row: Drag over the text you want to delete or correct, or double-click it, or

elect it using keyboard. Move the insertion point around in the text n the formula bar as

necessary. When the corrections have been ade. Press ENTER or click the check mark

button.

Replacing text:

If you activate a cell containing text, then new text and press ENTER or click the

check mark button, the w text will replace the old text.

Styling text:

You can change the appearance of both text and numbers in cells (make things hold or

bigger, change fonts, and so on).all the text in a cell is affected, but you can hoose to dify

only portions by selecting them.

4. What is formula? How to use formulas in Excel?

Formulas in MS Excel
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Formulas are the Bread and butter of worksheet. Without formula, worksheet will be

just simple tabular representation of data. A formula consists of special code, which is

entered into a cell. It performs some calculations and returns a result, which is displayed in

the cell.

Formulas use a variety of operators and worksheet functions to work with values and

text. The values and text used in formulas can be located in other cells, which makes

changing data easy and gives worksheets their dynamic nature. For example, you can quickly

change the data in a worksheet and formulas works.

Elements of Formulas

A formula can consist of any of these elements −

 Mathematical operators, such as +(for addition) and *(for multiplication)

Example −

o =A1+A2 Adds the values in cells A1 and A2.

 Values or text

Example −

o =200*0.5 Multiplies 200 times 0.15. This formula uses only values, and it

always returns the same result as 100.

 Cell references (including named cells and ranges)

Example −

o =A1=C12 Compares cell A1 with cell C12. If the cells are identical, the

formula returns TRUE; otherwise, it returns FALSE.

 Worksheet functions (such as SUMor AVERAGE)

Example −

o =SUM(A1:A12) Adds the values in the range A1:A12.

Creating Formula

For creating a formula you need to type in the Formula Bar. Formula begins with '='

sign. When building formulas manually, you can either type in the cell addresses or you can



K.MACHAR RAO, MCA Page 34

point to them in the worksheet. Using the Pointing method to supply the cell addresses for

formulas is often easier and more powerful method of formula building. When you are using

built-in functions, you click the cell or drag through the cell range that you want to use when

defining the function’s arguments in the Function Arguments dialog box. See the below

screen shot.

As soon as you complete a formula entry, Excel calculates the result, which is then displayed

inside the cell within the worksheet (the contents of the formula, however, continue to be

visible on the Formula bar anytime the cell is active). If you make an error in the formula that

prevents Excel from being able to calculate the formula at all, Excel displays an Alert dialog

box suggesting how to fix the problem.

5. Explain how to format text in Excel?

To format text in bold or italics:
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(1) Left-click a cell to select it, or drag your cursor over the text in the formula bar to
select it.

(2) Click the Bold or Italics command.

To format text as underlined:

(1) Select the cell or cells you want to format.

(2) Click the drop-down arrow next to the Underline command.

(3) Select the Single Underline or Double Underline option.

To change the font size:

(1) Select the cell or cells you want to format.

(2) Left-click the drop-down arrow next to the Font Size box on the Home tab.

(3) Select a font size from the list.

To change the text color:

(1) Select the cell or cells you want to form

(2) Left-click the drop-down arrow next to the Text Color command. A color palette
will appear. Select a color from the palette.

To add a border:

(1) Select the cell or cells you want to format.

(2) Click the drop-down arrow next to the Borders command on the Home tab. A
menu will appear with border options.

(3) Left-click an option from the list to select it.

6. Explain the features of MS. Excel?
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Microsoft excel is an integrated electronic spread sheet program developed by

Microsoft corporation. It includes the following features.

Autocalc: This feature is very useful to sum a group of numbers is selected them.

Their sum will automatically appear in the status area.

Auto complete: Excel now intelligence to anticipate what you are going to type!

Based upon entries you’ve already made, AutoComplete will try to figure out what you

intended to type, once you’ve entered few letters.

Autocorrect: Excel can support automatically correct mistakes.

Better Drag-and-Drop: Do you want to move a group of cells? Excel’s drag and

drop feature lets you reposition selected portion of your spreadsheet by simply dragging them

with your mouse.

Cell tips and Scroll Tips: To help you get around better with mouse, Excel now

includes scroll tips. When you click and drag a scroll bar, a small window tells you what row

or column you are heading for.

Number Formatting: It’s easy to format numbers with excel’s new number

formatting feature. Select your numbers and choose cells command from format menu.

Templates and Template wizard: Excel’s template facility has been greatly

enhanced. You can choose from a variety of elegantly designed templates for your home or

business.

Conditional Formatting: Conditional formatting helps users to quickly focus on

important aspects of a spreadsheet or to highlight errors and to identify important patterns in

data.

Sorting and Filtering: Excel spreadsheets help us make sense of large amounts of

data. To make it easier to find what you need,

Excel Charts: Excel charts help you communicate insights & information with ease.

By choosing your charts wisely and formatting them cleanly, you can convey a lot.

UNIT-III
Short Question & Answers
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1. What are text boxes in Excel? How do you use them?

Besides, typing text into cells, you can create text boxes and place them anywhere

you like on your worksheets. They are a kind of graphic object. It's even possible to rotate

text in text boxes, and draw arrows from text boxes to things the text describes. To create a

text box, click the text box button, then use your mouse to drag a box d desired size. Release

the mouse button and type. To create boxed text:

1. Click on the text box button, you will find it in Excel's drawing tool bar.

2. Drag to create outline of a text box in the appropriate desired size and shape. 3. Type and

edit your note using text-editing techniques.

2.What are text notes in Excel? How is it useful?

Text notes are used to hold notes that you don't what to display on your worksheets.

The notes are attached to cells, and can be viewed on screen.

Creating notes:

To create a note, start by selecting appropriate cell. Then choose insert/Note or press

SHIFT+ F2. Bal will display the all ne dialog

A red dot appears in the top-right corner of a cell that has a note attached to it. Type the note

in the text note box. Click adds or OK to attach the note to the cell. Displaying and printing

notes:

Select the cell of interest, then press SHIFT F2. You will see the cell note dialog box. To

print notes, visit the page set up dialog box click on the sheet tab and select the note option

box.

3. Explain how can we perform spell checking in Excel?
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Once you have entered the worksheet headings and other text, Excel's spelling

command on the options menu will launch the spelling checker, as will the spelling button on

the standard toolbar. Running the spelling checker:

To check the spelling of your entire worksheet. Run the spelling checker without

selecting range of cells. This checks labels cell notes, embedded charts, text boxes, headers

and footers. It does not check text created by formulas.

To check a small portion of the worksheet, select theappropriate range of cells. To

check a single word, highlight it in the formula bar and run the checker.

You can accept Excel's spelling suggestions, ignore them, type your own changes, or

add words to the custom dictionary as you do in word.

4. Explain about cutting, copying and pasting in Excel.

Cutting, copying & pasting:

Copying is useful to duplicate text or values to other portions of the worksheet or

even to another worksheet altogether. For example, you can quickly copy sales or production

figures from one worksheet to another or use copy to fill a budget category with the same

amount for every month. In contrast, moving a cell removes it from the original location

(rather than duplicating it), so you can place it elsewhere on a worksheet.

When you use the Cut or Copy commands, selected data is sent to the clipboard,

which is a temporary area in memory that holds the information. From the clipboard, you can

paste the data to other locations. By default, when you paste the clipboard's contents. Excel

transfers both the cell contents and format to the new location.

UNIT-4
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Essays Question & Answers
1. Explain the various parts of PowerPoint window.

You use commands to tell PowerPoint what to do. In PowerPoint 2007, you use the

Ribbon to issue commands. The Ribbon is located near the top of the PowerPoint window,

below the Quick Access toolbar. At the top of the Ribbon are several tabs; clicking a tab

displays several related command groups. Within each group are related command buttons.

You click buttons to issue commands or to access menus and dialog boxes. You may also

find a dialog box launcher in the bottom-right corner of a group. When you click the dialog

box launcher, a dialog box makes additional commands available. Slides, Placeholders, and

Notes:
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The Status bar generally appears at the bottom of the window. The Status bar displays

the number of the slide that is currently displayed, the total number of slides, and the name of

the design template in use or the name of the background.

The Outline tab displays the text contained in your presentation. The Slides tab

displays a thumbnail of all your you click the thumbnail to view the slide in the Slide pane.

Slides.

The View buttons appear near the bottom of the screen. You usethe View buttons to

change between Normal views, Slider Sorter

View and the Slide Show view.

2. How to create a PowerPoint presentation? Explain.
Create a Title Slide:

When you start PowerPoint, PowerPoint displays the title slide in the Slide pane. You

can type the title of your presentation and a subtitle on this slide. To enter text:

(1) Click and type the title of your presentation in the "Click to add title" area.
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(2) Click and type a subtitle in the "Click to add subtitle" area. If you do not wish to use the

title slide, click the Delete Slide button in the Slides group on the Home tab.

Create New Slides:

After completing your title slide, you can create additional Slides.

To create a new slide:

1. Choose the Home tab.

2.Click the New Slide button Slide in the Slides group. The Office Theme dialog box appears

and displays several layout templates.

3. Click the layout you want. The layout appears in the Slide pane of the PowerPoint window.

4. To add text, click inside the placeholder and type.

5. To add an additional slide to your presentation, do one of the

Following: Right-click the slide layout. A menu appears. Click Layout and then click the

layout you want.

Choose the Home tab, click the New Slide button New Slide, and then choose the slide layout

you want.
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3. Explain the following in PowerPoint.

a. Making changes in slides.

b. Applying a theme to a slide.

c. Adding a background.

d. Running a PowerPoint slide show

(a) After creating a slide, if you want to add text:

1. Place the mouse pointer at the point at which you would like to add text.

2. Type the information you want to add.

If you would like to change text;

1. Select the text you want to change.

2. Type the new text. You can use the Backspace key to delete text. You can also delete text

by highlighting the text and pressing the Delete key.

(b) A theme is a set of colors, fonts, and special effects. Themes provide attractive

backgrounds for your PowerPoint slides. To apply a theme to all of the slides in your

presentation:

1. Choose the Design tab.

2 Click the More buttons in the Themes group.

3. Click the design you want. To apply a theme to selected slides:

1. Click the Slides tab, located on the left side of the window. 2. Hold down the Ctrl key and

then click to select the slides to which you want to apply a theme.

3. Choose the Design tab.

4. Click the More buttons in the Themes group. 5. Right-click the theme you want to apply.

A menu appears.

6. Click Apply to Selected Slides. Excel applies the theme to the slides you selected. You can

add a dramatic effect to your theme by applying a background

1. Choose the Design tab.

2. Click the Background Styles button Background Styles

3. Click the background you want.
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(c) Adding a background:

1. Choose the Design tab,

2. Click the Background Styles button Background Styles

3. Click the background you want. PowerPoint applies the background to your slides.

(d) Running a PowerPoint slide show: After you create your slides, you can run your slide

show:

Do any one of the following:

(1) Press F5.

(2) Choose the Slide Show tab. Click the From Beginning button in the Start Slide Show

group.

(3) Click the Slide Show icon in the bottom-right corner of your screen.

Your slide show appears on your screen.
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4. How can you customize a presentation?
Working with slides: Make a new slide:

1. On the common tasks toolbar, click new slide.

2. Scroll to see more layouts, and then click the one you want Delete a slide:

3. Select the slide you want to delete.

4. On the edit menu, click delete slide.

Copy a slide from one presentation to another:

(1) Select the slide you want to insert another slide after.

(2) On the insert menu, click slides from file.

(3) Find and select the presentation you want to copy a slide

(4) Select the slide or slides you want to copy, and then click from. Insert.

Change the layout of a slide:

(1) In slide or slide sorter view, select the slide you want to change.

(2) On the common tasks toolbar, click slide layout.

(3) Use the scroll bar to view all layouts, click the one you want, and then click apply.

(4) Rearrange any overleaping or hidden

Change the way text looks:

(1) Select the text you want to change.

(2) On the format menu, click font.

(3) Select the options you want such as font, font size, color, bold, italic, underline etc.

Position text in an object:

(1) Select the object that has the text you want to position.

(2) On the format menu, click auto shape, and then click the text box tab.

(3) In the text anchor point box, click the position the text to start in. you want

5. Explain the Features of M.S.Power Point?
Power point helps you quickly to create update and sort "slide based Professional

looking presentation materials. Power pentin a program that helps to create.

(1) Black and white overhead transparencies

(2) Color overhead transparencies (3) 35mm slides

(4) Computer screen and video slide shows complete with special effects. (5) Presentation

files.
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(6) Printing the meeting hand-outs.

(7) Detailed speaker's notes.

(8) Printed and on screen presentation outlines.

Power point provides rehearsal tools that let you practice your presentation at our

desks. Power point is a presentation tool that will help you to capture and hold people's

attention. You can use power point to create slides which can be arranged in presentation. We

can print handouts and speakers notes. Power point provides a well-defined slide formats for

35 mm Slides, overhead transparencies, on screen presentation and printouts. We can use

designs as it is or we can change it. Auto content wizard that helps to prepare commonly

given presentations. Auto content wizard can begin the presentation, providing outlines and

major topic headings.

6. What are the various parts of slides in PowerPoint?
Different types of slide layout in PowerPoint

PowerPoint business uses

A PowerPoint layout is essential for all companies (large groups, ETI, SME, TPE) with more

than 10 PowerPoint users.

For example:

Title Slide layout

The title slide layout is very important. It is a preview of the upcoming content for the

rest of your presentation. Quality cover shows your audience how carefully your project has

been handled. The most obvious benefit of using a title slide is informing listeners of what

they will see and learn. Consider a title slide as a cover of a book or report. The cover mask

gives the tone, the graphic chart and the artistic direction of the slideshow.
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In a title slide layout the editable parts are usually the background image, the title,

subtitle and some optional elements such as the date, or the name of the presenter.

Table of content Slide Layout

A table of contents will give your audience an overview of your Powerpoint

presentation. It must be clear and precise in order to facilitate the general understanding of

the subject.

The editable elements of a Summary slide layout are the titles of the different parts of

your presentation as well as the number of the corresponding pages. Even though the table of

contents is at the beginning of the slideshow, it will be the last one written.

Simple Text Content Slide layout

Simple Content slide layout includes the title of the slide, a subtitle, and a central text box.

All these elements are editable.
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Two Text Content Slide layouts

The two content slide layouts is a variant of the previous mask. The main advantage

of dividing the text into two blocks is to make reading more smooth and enjoyable, especially

if the text is long.

The editable elements are the title, a possible subtitle and the two text blocks.

Content Slide layout [Text + Picture]
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The Content [Text + Picture] slide layout offers a design that allows you to insert text and an

image in 2 spaces reserved for this purpose. This type of mask can be declined in several

variants with a horizontal or vertical permutation of the boxes.

The editable elements are the title, the possible subtitle, the body of the text and of course the

image.

Content Slide layout [Texts + Pictures]
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This layout is an extension of the previous one that allows to insert several texts and several

images on the same slide. There can be different variations, with 3 boxes or more, with

horizontal or vertical permutations.

The editable elements are the title, the possible subtitle, the body of the text and the images.

Impact Message Slide Layout

It’s a very popular Layout for an Important Message. It is used to highlight a key message or

a strong quote. In this case, the mask design favors a central text box that is highlighted by

side boxes containing images.

The reader’s eye is guided towards the main information.

Editable elements are title, subtitle, images and text.
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UNIT-IV
Short answers

1. How to create templates in PowerPoint?
1. Open a blank presentation, and then on the View tab, inthe Presentation Views group, click

Slide Master. 2. On the Slide Master tab, in the Edit Master group.Click Insert Slide Master.

3. Customize the slide master.

4. On the Slide Master tab, in the Master Layout group,click Insert Placeholder, and then

click Text.

5. Click a location on the slide master, and then drag to draw thePlaceholder.

6. Type descriptive text that prompts the users of your template to enter specific information.

Save a presentation as a PowerPoint template (ppt)

1. Click the Microsoft Office Button and then click SaveAs.

2. In the File name box, type a file name, or do nothing to acceptthe suggested file name.

3. In the Save as type list, click PowerPoint Template, and then click Save.

2.Explain the procedure for adding slides to a PowerPoint

Presentation.
1. On the View tab, in the Presentation Views group, click Normal.

2. In the pane that contains the Outline and Slides tabs, click the Slides tab, and then click a

location between two slides where you want to add a new slide.

3. On the Home tab, in the Slides group, click New Slide.

4. On the Home tab, in the Slides group, click Layout, and then select a slide layout that will

best accommodate the content that you plan to add to the slide.

5. Add text to the new slide.

3.How to insert a sound in a PowerPoint presentation?

1. Select the slide to which you wish to add a sound.

2. In the Insert tab, under the Media Clips group, click the arrow on the button. Choose

Sound from File... to bring up the Insert Sound dialog box.

3. Find the sound file on your computer using the "Look In" drop- down. Select the file and

click Ok.
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4. A pop-up box will appear asking you how you would like the sound to start in the

presentation. Choose to either have it play automatically or to have it play only when clicked

.5. A sound icon appears on your slide.

4.What is custom animation in PowerPoint? Explain.

Custom Animation is a feature in Microsoft Office PowerPoint. It contains a list of effects

that you can apply to objects to have them animate during the slide show.

Entrance effects:

Entrance effects animate object so that it enters the slide show. During the slide show view,

you won't be able to see the object until it starts to animate. Hence, if two entrance effects are

added onto an object one after another, the object will disappear when the second effect starts

to animate.

Emphasis effects:

Emphasis effects animate object on the spot during slide show. The end result will stay there

unless Auto-Reverse under the effect tab or "Rewind when done playing" under the timing

tab have been checked.

Exit effects:

Exit effects animate object so that it leaves the slide show. During the slide show view, the

object will disappear from the screen based to the effect that you have added. They can be re-

called by adding an Entrance effect.

Motion Paths:

Motion Paths animate object by moving it from one position to another. This feature is

similar to Motion Twining in Adobe Flash, but much simpler to manipulate with. PowerPoint

provides a wide range of Motion Paths to choose from.
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UNIT-4

Essay Question & Answer
1. What is MS Access? Explain different components of MS Access.

MS-Access is a Relational Database Management System (RDBMS) used to store and

manipulate large collection of information.

Components of MS-Access:

(1) Database window: MS-Access is object oriented software. In Ms-Access, we can

manage objects through the database window. The Database includes tables, queries, forms,

Reports, macros and modules. The Database window also include three buttons. They are

Open: This activates the selected objects. Design: This opens selected object in design view.

New: This starts the process of creating new object.

(2) Tables: Database is a collection of information retained in the form of table. Table

consists of rows and columns. Each table stores information about one entry such as student,

customer, and product, patient. Each row in a table represents a single record of an entry.

Each column consists discrete elements of information.

(3) Forms: Forms display the data from a table (or) query in the format requested by

user. The records (or) fields in the table are placed in the forms and can be edited according

to the requirement.

For example, user can create a form having Roll number, Name and class of a student

ignoring the other fields in the student table: Once a form is designed and saved, it can be

used to add, modify or delete information within the respective table.

(4) Queries: A query is a question asked by the user to extract information according

to his/her requirement.

For example, a query can be created that asks for the list of students who have secured

more than 70% (or) asks for the detail of INDIAN residents in USA. The result of a query is

displayed in the form of data sheet. A query changes with the contents of the supporting data.

(5) Reports: A report displays the information in a prescribed format. MS-Access

produces the reports by incorpo-rating graphs, charts and different styles. It can be used to

group data and show subtotals and grand totals. MS-Access enables a user to design reports

according to need.
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(6) Macros: Macros are used to automate frequently used tasks. Access Macros execute

number of actions such as opening files, displaying message boxes, validation of data.

(7) Modules: Modules are programs that advanced uses create with MS-Access Basic, a

programming language. These programs can perform complex operations not possible with

Ms-Access alone oreven Access with macros.

There are two types of modules in MS-Access. These are: (1) Global modules (ii) Report

modules.

2.What are the advantages and features of MS Access?

Databases are designed to offer an organized mechanism for storing, managing and

retrieving information. Basically database management involves the functions of data storage

and retrieval In some occasions data stored in a database may be edited and manipulated

according to the requirements. MS-Access is a perfect tool to do all these kinds of functions.

Advantages of MS-Access:

MS-Access has very easy operating procedure compared to Other database

management tools that are available. Also this is fairly cheaper and can be installed in most

of the computers. Another advantage is, it provides excellent graphical user interface (GUI)

whereas most database management tools provide console operating interface (CUI). This

feature creates excellent User- friendly environment. Table creation for database management

is easily done here. That is direct interaction with tables created andediting are possible.

Table creation is done directly by typing its name, property etc, this leads to easy operation

whereas other have complex syntaxes for creating these. There is no need for the user to have

high programming knowledge for using MS-Accs. So, users with basic computer knowledge

can use it. Special

Features of MS-Access:

Table creation is simply done by design or wizard options. Data entered and stored in

MS-Access can easily be exported or pasted into spreadsheets or statistical software for

further analysis. As part of the MS Office Suite, MS Access integrates seamlessly with MS

Word and Excel. Any data stored in MS-Access can be easily used throughout the MS-Office

applications. For example. Names and addresses that are stored in an access database can be

imported and used in MS-Word directly. The real advantage of MS-Access is its relational

ability that allows users to join tables, using fields common to both, thereby allowing users to
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extract data from one table that relates to data in another. Data from separate tables can easily

be joined to produce a new file for further analysis: Next Function named "Forms provides

means to develop data entry interface for users. The Report Writer" function in MS-Access is

one of the best available. The stored data can be given in a wonderful format to take print or

any other purpose another aspect of insuring valid data is making sure that there is no data

duplication. The development environment that MS Access provides supports rapid

application development. In general users with little programming knowledge can use MS

Access effectively. There are useful menus like "File, Edit etc., to provide users a very

effective usage of good database management. There is no console window, no complex

Syntaxes, and no complex queries for Ms-Access. These are common characteristics of most

of the database management tools.

3. Explain the procedure to create databases without the wizard.

Follow these steps to create a new table without using wizard

(1) Open the database that needs a new table, or create a new database (CTRL + N)

(2) If necessary, click on the table tab to bring it to the forefront.

(3) Click the new button in the database window.

(4) Click on Design view in the new table box and click OK.

(5) You will see an empty table window.

In the above window type field names and put into effect other design decisions.

To create a table, follow these general steps.

(1) Type a field name.

(2) Pick a data type

(3) Specify any necessary properties.

(4) Repeat steps 1 through 3 for the remaining fields.

(5) Save the table.

4. List and explain various properties of text fields.

There are ten possible text field properties. They are field size, format, input mask,

caption, and default value, validation rule validation text, required, allow zero length, indexed.

Field Size: The field size of text field can be anything from 1 to255 characters.

Format: The format property forces entries to appear according to the characteristics you

specify. For instance, to force all text to uppercase, regardless of how is entered, you can

place a> symbol in the space next to format.



K.MACHAR RAO, MCA Page 55

Input Mask: Input masks provide things like parenthesis around area codes in telephone

numbers, time and date codes formats and so on. Caption: The caption property lets you

specify replacementtext for the name of the field whenever you create a new record.

Validation Rule: This property lets you specify a value that will be automatically entered into

thefieldwhereveryoutage reward

Validation Rule:This property lets you specify error checks.

Required: Use this Yes/No field to tell Access if an entry is required in the field you are

designing.

All zero length: Zero length data i.e. null is allowed. Indexed: Use this Yes/No field to tell

Access, if a field is to beindexed for speedy lookups.

5. Explain about the data types and properties available in MS
Access.

The following list summarizes all the field data types available in Microsoft Access,

their uses, and their storage sizes.

Text: Use for text or combinations of text and numbers, such as addresses, or for numbers

that do not require calculations, such as phone numbers, part numbers, or postal codes.Stores

up to 255characters. The FieldSize property controls the maximum number of characters that

can be entered.

Memo: Use for lengthy test and numbers, such as notes ordescriptionsStores up to 65,536

characters.

Number: Use for data to be included in mathematical calculations, except calculations

involving money (use Currency type).Stores 1, 2, 4, or 8 bytes; stores 16 bytes for

Replication ID(GUID). The FieldSize property defines the specific Number type

Date/Time: Use for dates and times.Stores 8 bytes

Currency: Use for currency values and to prevent rounding ofduring calculations. Stores 8

bytes.

AutoNumber: Use for unique sequential (incrementing by 1) random numbers that are

automatically inserted when a record added.

Stores 4 bytes, stores 16 bytes for Replication ID (GUID) Yes/No: Use for data that can be

only one of two possible values, such as Yes/No, True/False, On/Off. Null values are not

allowed.Stores 1 bit.
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OLE Object: Use for OLE objects (such as Microsoft Word documents, Microsoft Excel

spread sheets, pictures, sounds, or other binary data) that were created in other programs

using the OLE protocol.

Stores up to 1 gigabyte (limited by disk space).

6. What are various parts in an Access Expression?

There are four types of objects in MS access:

1. Tables– Tables are the places where any information is stored. The most basic work of any

database is to store useful information, and tables are meant for that purpose.

2. QUERIES- Queries are statements asking the software to conduct a detailed search from

the database. Consider the example of a library having at least 1000 books. Now, there

would be a database where all the relevant information of those books is stored. You don’t

have to search the whole database to get that book’s information if you need a particular book.

3. FORMS– Forms display data from your table itself and help perform the necessary tasks.

Forms are basically an easy way to guide people using the software to perform various

operations like sorting, adding, displaying in a more presentable manner, and so on.

Whatever you do in a form, you are actually doing it on the table itself. You can directly do it

from the table also

4. REPORTS- Reports are static, easy to understand, and easy on the eyes documents, which

are presentable and portable. Colors can be added to it, and it & will help in better managing

the data that we need to present to someone. Reports are the objects which help in

showcasing a particular section in order to highlight the important section.

5.MACROS– Macros in MS access are used for automation purposes. It can automate tasks

like opening forms, querying, changing values, or even running other macros. It helps in

adding functionality to your forms, reports, and controls. This helps in improving efficiency

when using the database.

If you need to manage the data well, then coordination of all four entities is required. If you

consider the case of a book directory in a library, then the place where all the information of

books is stored is called tables.

UNIT-V
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Short Question & Answer

1. What is the use of MS-Access in handling database?

MS-Access is a Relational Database Management Systems (RDBMS) used to store and

manipulate large collection of information.

Features of MS- Access:

(1) MS-Access is one of the well-known implementations of the relational data model.

(2) It is considered as part of an integrated set of tools for creating and managing database.

(3) The database applications for Ms-Access may range from personal Applications

(4) MS-Access provides a database engine and a graphical User interface.

(5) It provides a programming language called Access Basic.

(6) It also provides the database developer with hyperlinks as a native data type.

(7) Access allows interactive definition of relationships between tables which can specify

referential integrity constraints

(8) It create forms that make it easier to enter information

(9) Generate meaningful and insightful reports that can combine text, data, graphics and even

sound.

2. What are the various ways to rename a field both in data sheet
and design view?

Change a field name in a table:

You can change a field name at any time without affecting the data in the field. Microsoft

Access automatically fixes common side effects that occur when you make changes to a field

name. We can change the field name in either design view or data sheet view.

Change a field name in Design view:

Open the table in Design view.

Double-click the field name you want to change.

Type the new field name, following Microsoft Access object-naming rules.

Click Save on the toolbar to save your Change a field name in Datasheet view:

Open the table in Datasheet view Changes.

Double-click the field selector of the field that you want to the new field name, following

Microsoft Access object-change.

Type naming rules.
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Press ENTER to save the new name.

3. List the data entry and navigational shortcuts in MS Access.
Use a combo or list box:--

To do this Press

Open a combo box. F4 or Alt+Down arrow
key

Refresh the contents of the Lookup field list box or a combo
box.

F9

Move down one line. Down arrow key

Move down one page. Page down

Move up one line. Up arrow key

Move up one page. Page up

Exit the combo box or list box. Tab key

Edit and navigate the Object list:-

To do this Press

Rename a selected object.

Note: You can only rename an object when it is closed.

F2

Move down one line. Down arrow key

Move down one window. Page down

Move to the last object. End

Move up one line. Up arrow key

Move up one window. Page up

4. How to view and delete relationships in Access?

Deleting Relationship we can:

If we want to delete a relationship we can right click on the relationship we wish to delete and
select the Delete option from the contextual menu, or

Click on the relationship we wish to delete and select the Delete option from the Edit Menu
or,

Click on the relationship so that it remains selected and next press the Del key.
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The relationship will have been deleted from the window and the database.

Showing Direct Relationships:

This option permits us to visualize all the relationships based on a specific table in the
Relationships window, to do this:

Position yourself in the Relationships window and choose

Between:

Right click on the table and select the Show direct option in the contextual menu that appears.

Click on the table to select it and select the Show direct option from the Relationship Menu.

Click on the table to select it and then click on the button.

All the relationships associated with the table and all the tables related in these relationships
will now appear.
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